Readme

Collapse
No announcement yet.

fuel pump won't prime (don't think it is the relay)

Collapse
X

fuel pump won't prime (don't think it is the relay)

Collapse
 
  • Filter
  • Time
  • Show
Clear All
new posts

    fuel pump won't prime (don't think it is the relay)

    I recently had problems starting my car. If I sit there with the key turned for a while I will hear the pump prime whenever it feels like it. I hear a click when i turn the key from the relay but no prime. Then all the sudden I hear a second click and it primes up. Now it won't prime at all and I tried a new relay already. I have a walbro pump and the relay really isn't that old cuase I changed it a while ago. But I have a constant cel light on. Need my car running cause it's killing my side painting business. any info appreciated.

    #2
    what is the cel code?

    Comment


      #3
      jiggle your ecu connectors, check the ground on the thermostat and possibly the one on the rear of the trunk.

      Comment


        #4
        where is the one on the trunk? I will ck that. the cel is for something completely different. The light just stays on until it primes, so basically it's just saying there is something wrong. The cel was 20 and 21 and 21 is just because of how I have it wired. The relay isn't bad and I was looking at the diagram for the wiring today. I need the ck the ignition switch, but not sure if its that either. The one on the thermostat is good. I just really need help here it's a pain in the ass to walk out and wait for your fuel to prime when it decides to. Thx for those who posted.

        Comment


          #5
          I just had the same thing and it was the ignition switch cost about $40. dollars and about hour to put in.

          Comment


            #6
            Try replacing ur main relay...i had same problem ...put one in and no problem since

            Comment

            Working...
            X