Readme

Collapse
No announcement yet.

Code 43 (Changed everything and still)

Collapse
X

Code 43 (Changed everything and still)

Collapse
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Code 43 (Changed everything and still)

    I've been having code 43 for a year now and I've changed the PCV valve, MFR, fuel regulator, fuel filter, O2 sensor, fuel pump and today I just changed the fuel injectors. And that pesky code 43 is still popping up

    I changed the spark plugs and wires with the rotors about a year and a half ago. I just checked the distributor visually and I didn't see any metal shavings or oil inside.

    About a week ago the car started losing power, feels like the fuel is getting cut off especially up hill, the tachometer was bouncing erratically as well... that's why I finally changed the injectors. After installing the new RC injectors the car wasn't losing power but something else happened. While I was cruising, about 60 mph, then suddenly the car shut down as if someone turned the ignition off. Luckily I was able to steer and stop the car on the shoulder since every pressure on the car just dropped. I started the car again and it started with no problem.

    I've searched and searched on this forum but I didn't find anything that can help me. I'm just wondering if you guys could help me out. What else did I miss, the only thing I could think of now is the ECU or maybe something electrical. I would really appreciate any suggestion. Thanks!


    My car is 91 integra, LS with a stock B18A1.

    #2
    Sounds like the ignitor, or ICM. Happened to me, car was losing power and tach was bouncing sporadically. Ended up being a two fold issue for me. 1. the distributor's oil seal was bad, letting small amount of oil into the unit. 2. The ignitor was going bad. Changed the ignitor, and the tach started working fine, but still some power loss. Eventually went obd1 and had to change the distributor, that fixed the oil problem. Now I don't have any power loss at all.

    Comment


      #3
      damn im having the exact same problem with my car right now....the mph needle jumping,low power,light gray smoke...also due to the low power if i step on the gas pedal a little bit too much i hear like clicking noises from the engine...not sure what the hell is going on but i need to figure this out...lol...im getting a code 43, and a code 12 egr.....any suggestions???

      Comment


        #4
        egr can affect fuel useage. maybe the egr needs cleaned or just replaced

        Comment


          #5
          ive had a code 43 for a looooong time. i found out it was a shortage in the wiring harness for the o2 censor so i bypassed it and re wired it from the ecu

          Comment

          Working...
          X