Readme

Collapse
No announcement yet.

burning oil and random misfire......need suggestions/ideas

Collapse
X

burning oil and random misfire......need suggestions/ideas

Collapse
 
  • Filter
  • Time
  • Show
Clear All
new posts

    burning oil and random misfire......need suggestions/ideas

    ok engine has 241,xxx miles compression is within spec on all 4 cylinders, great power, actually chirps second gear every now and then haha, it burns a little oil and smokes consitantly STARTING at 3000 rpms with light throttle and just cruising. Also as that starts i get a slight stumble/miss from 3-4000 rpms light to mid throttle. under hard throttle no miss anywhere and definitely smokes/burns oil.

    no wwith high milage i can see the rings being worn yes, but compression is in spec and definitely no loss of power...... so im thinking my valve stem seals are shot, cause oil to be sucked in on the intake stroke while the valves are open?.?.??? could this be?
    any other suggestions, thoughts, or ideas MUCH appreciated

    thanks

    #2
    misfire could be a vac, plugs and such.

    Comment


      #3
      The oil burning will probably be the fault of the oil control rings not the compression rings. If the oil control rings are gone u wont notice any power loss either.

      Comment


        #4
        any other ideas on the misfire issue?

        Comment


          #5
          did u check for a vac leak? how did the plugs look

          Comment

          Working...
          X