Readme

Collapse
No announcement yet.

Weird Idle issue concerned about it.

Collapse
X

Weird Idle issue concerned about it.

Collapse
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Weird Idle issue concerned about it.

    I have a weird situation here.. I just recently purchased the car and it had the check engine light on. I checked the ECU (91) light and got 7, 13, 14...
    I also had a faulty thermostat so I replaced it and the check engine light hasnt come back on and the ECU light blinks one time which I show is Heated 02 sensor in the helms manual.. What is going on here? And I can't stand the idle issue goes from 800 to 2k


    #2
    I took a picture of the top of the engine I could have some hoses missing or mis connected? I just purchased the car like this and it has intake with two holes and one is plugged up. One is coming from the head to the intake and one from that little valve next to the accelator that has a black hose plugged up with a screw in the end of it.

    Comment


      #3
      Check the IACV (idle air control valve) this may cause this problem!!!

      Comment


        #4
        Yeah I havent had a chance to disconnect and clean it yet but I was wondering why if before it was throwing 3 different codes now none of those are their but a new one appeared... car drives fine if i put the ac on the idle wont jump aroundn but if i turn it off it will.

        Comment


          #5
          Clean the FITV/IACV, replace o2 sensor...then report back with results.

          Comment


            #6
            Try oxygensensorsforless.com thats where i got mine. Also, why is there a tree air freshener to the left of your intake??

            Comment


              #7
              Haha, I didn't notice that the first time I looked at the pics.

              Comment


                #8
                Bad idle with ac off can mean one thing bad ground voltage

                Comment


                  #9
                  Originally posted by GERMS:DA9 View Post
                  Bad idle with ac off can mean one thing bad ground voltage
                  Holy old thread resurrection, batman!

                  Comment

                  Working...
                  X