Readme

Collapse
No announcement yet.

Difficulty shifting. (Automatic)

Collapse
X

Difficulty shifting. (Automatic)

Collapse
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Difficulty shifting. (Automatic)

    Within the past couple of weeks i've had some trouble shifting from park into drive... or anything else into drive. It feels like it gets stuck. Sometimes I have trouble getting it out of drive and into park or reverse as well. I have no leaks or anything, but I unfortunately cannot find the paper I keep in my car for all my major repairs/routine repairs. So I actually cannot remember the last time I had my transmission flushed.

    Anyone think that's what needs done here, or is it something else? Could something just need greased? I have a week off after the 4th of July, so i'm planning on trying to get this taken care of that week. That and the trouble getting it into drive during cold weather too. So if you guys think I just need to slap some grease down, I can do that while i'm doing the cold shift fix.

    #2
    i'd get the cable linkage checked. or check it urself. whenever u move the shift lever, it is connected to a cable, which is connected to a bracket thing on the trans. that bracket and the shaft its attached to might be all rusted or something and is sticking/rusting/etc in there.

    Comment


      #3
      do you have a hard time shifting into park like does it take a while to register on your dash what gear you are in .

      Comment


        #4
        No, I physically have a hard time putting it into gear. It'll stop in between gears, and I have to hit it up (or down) to put it into the gear I want to. It's intermittent. I'm gonna go on wednesday to get the fluid changed, and see if that helps.

        Comment


          #5
          Originally posted by Wallyballjacker View Post
          No, I physically have a hard time putting it into gear. It'll stop in between gears, and I have to hit it up (or down) to put it into the gear I want to. It's intermittent. I'm gonna go on wednesday to get the fluid changed, and see if that helps.
          fluid isn't gonna change how it physically works. u can have a COMPLETELY DRY transmission, and still be able to move the shift lever n bracket/linkage.

          if u pay attention to where the shift lever connects to the cable/linkage....... follow it to where it hooks up to the transmission...... then you'll understand what i'm talking about.

          Comment


            #6
            I do get what you're talking about now. I took it to a honda/acura specialist down the road, and he said it's definately the cable you're talking about. $250 installed. I had him order the part today.

            Comment


              #7
              Originally posted by Wallyballjacker View Post
              I do get what you're talking about now. I took it to a honda/acura specialist down the road, and he said it's definately the cable you're talking about. $250 installed. I had him order the part today.
              glad to hear u got it taken care of.

              Comment


                #8
                Just curious if you got your Auto-trans cable replaced and if that did the trick for you? I've got one doing the same thing and was curious. Thanks

                Comment


                  #9
                  sorry to bring this up from the dead, but you got ripped off $250 installed for a cable that is held in by a bitch pin,2 10mm bolts and a cotter pin. it would have been cheaper to do it yourself.

                  Comment


                    #10
                    Originally posted by hondattic View Post
                    do you have a hard time shifting into park like does it take a while to register on your dash what gear you are in .
                    My car is doing exactly this. It takes up to a minute sometimes for it to register in Park on the dash. I just have to sit and wait since I cant take the key out. Any ideas?

                    Comment


                      #11
                      its definetly you gear position selector switch a very common auto tranny problem on the g2 tegs http://www.g2ic.com/forums/showthrea...osition+switch you dont have to replace it you can try to clean it first hope this helps.

                      Comment

                      Working...
                      X