Readme

Collapse
No announcement yet.

Starting problem

Collapse
X

Starting problem

Collapse
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Starting problem

    Hey guys

    Last week, it was a cold day and my car started just fine in the morning. I went to my class. After the class, I start my car and i noticed that the lights were slightly dimm. I thought it was just because it was cold and or something. But as i turned on the heater and stereo, I noticed my clock getting dimmer. I turned off the car, tried to turn it on back. Nopes. It didn't start. Jump started the car somehow and drove it back. But as i turn it off, it wouldnt start again. I had my alternator replaced a little over a year. Battery was replaced over the summer. When I jump start the car. I does start but i could smell something strange near the alternator. How can an alternator go bad in a year ??? I also noticed that my AC belt was very loose. I'm not in as position to spend 300 bucks on alternator. Any help would be appreciated.... Thanks

    Mo.
    Last edited by CrazyTeg; 09 Dec 2004, 17:31:07.

    #2
    http://www.g2ic.com/forums/showthread.php?t=40859

    sounds like your belts weren't tightened properly, causing your alternator to go bad. depending on where you bought the alternator there should be some kind of warranty. i'd look into it.

    Comment


      #3
      Thanks man..
      I think it's alternator. I went to Autozone with the battery. They said that battery was weak but after charging it, it works fine. So the alternator is bad. What should I do now ??????? Any cheap way ??

      Thanks guys.

      Comment


        #4
        get it rewound, or buy a rebuilt unit. far cheaper than 300 bucks.

        Comment


          #5
          Junkyard for around 35 bucks and you could even say it's oem.

          Comment

          Working...
          X