Readme

Collapse
No announcement yet.

Clutch Pedal "Clicks" at 2500rpm (Intermitent)

Collapse
X

Clutch Pedal "Clicks" at 2500rpm (Intermitent)

Collapse
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Clutch Pedal "Clicks" at 2500rpm (Intermitent)

    Just recently my clutch pedal started to click and actually pop at around 2500rpm. I will shift normally: put clutch pedal in, shift gears, slowly release pedal and at 2500rpm (OR SO) the pedal it self will make a Click or Pop noise. I can actually feel the pedal pop, but if it's actually moving is hard to say. I adjusted the clutch cable after it started happening and it solved the problem for about 5 minutes. Now it's very intermittent, happens just as often as it doesnt.
    Also, when it does do the popping, the clutch pedal feels a bit "gritty" when pushed all the way down and it also makes shifting into 2nd tougher than it should be. But when it's feeling fine, it shifts smoothly, feels very smooth, and doesnt pop at all.

    This is all with a BRAND NEW CLUTCH installed 4-5 months ago.
    Any suggestions would be so Great!! Thanks!

    #2
    I got the same problem with my car. The popping sound is only when you let up off the clutch. I havent gotten it looked at or even driven the car since. I think my clutch is worn out so im planning on replacing the whole thing. Its probably something with the pressure plate though, Ive had my car for about 2 years and havent changed the clutch since buying it used, so yours might be messed up too, but let us know Im not really sure exactly what it is.

    Comment


      #3
      Well the clutch was replaced at the end of August, so I doubt anything is the matter with the clutch/pressure plate.

      But thanks for the insight.

      Comment


        #4
        Possibly bad synchros in the transmission

        Comment


          #5
          Wow, I'm really hoping it's nothing like that...

          I was hoping somebody would say, "Oh it's probably just a bad clutch cable" or something not too important.... Well the more I know, the better off I am. ANy other possibilities?

          I just drove home from work, and it felt buttery smooth...It's happening less now. Hmmmmm...*crosses fingers for an 'easy' fix*

          Comment


            #6
            Well I'm doubting the idea that it is synchro related. Because it just happened as I put it into neutral and it popped as I was letting off the pedal. As far as I know, there is no synchro for nuetral. Plus, it happens in when shifting into ALL gears, it doesn't discriminate.

            Hmmm I guess I'll try adjusting the clutch cable some more when it stops pouring outside.

            Comment


              #7
              use some spray grease..like white lithium grease....and spray it around everything that moves up by the pedal....and also look to the left of the heat shield..and spray the little arm that the cable pulls...that helped when my pedal would feel like it was sticking..give it a shot cant hurt

              Comment


                #8
                Originally posted by BGdubs92b17
                use some spray grease..like white lithium grease....and spray it around everything that moves up by the pedal....and also look to the left of the heat shield..and spray the little arm that the cable pulls...that helped when my pedal would feel like it was sticking..give it a shot cant hurt
                Good idea! I've sprayed moving arm on the transmission housing, as well as the cable itself. I'll do some liberal spraying on the pedal itself! I'm dumb for not thinking of that Thank you much!

                Comment


                  #9
                  I've sprayed the pivoting arm some more, sprayed the clutch pedal assembly and still nothing

                  It still is "popping" and it's getting even more annoying that I thought possible.

                  hmmm.

                  Comment

                  Working...
                  X