Readme

Collapse
No announcement yet.

IACV broken!!! Please help!!!

Collapse
X

IACV broken!!! Please help!!!

Collapse
 
  • Filter
  • Time
  • Show
Clear All
new posts

    IACV broken!!! Please help!!!

    Hi guys,
    My 92 teg has a bouncing idle so I went ahead and clean the iacv today. I took the unit out and cleaned it with carb cleaner and simple green. When I put it back on after cleaning it, the entire unit stop working. The car would died if I don't step on the gas. I unplug and plug the thing back on thinking it might be a lose connection, but it still doesn't work. Is my iacv busted? I need to replace it? If yes, anyone know any chain store that stock it? I checked autozone and kragen's website and they don't seem to stock it.

    thanks

    #2
    hmm take it back off and make sure you get ALL the simple green out of there. Then make sure that all of the carbon cleaner is out. the carbon cleaner will make your engine run like the IAC is broken, because it bogs the engine and burns the carbon out. Once it is all burned out it will work fine again.

    The first time I cleaned my IAC i didn't have an air compressor to blow and dry all the Carb cleaner, and i just let my car idle for a long time while all the rest of the cleaner went through the engine.

    Good Luck

    Comment


      #3
      How long is a long time? i'll try it later and hope it works.. it'll save me some money in replacing it.

      thanks alot

      Comment


        #4
        open the iacv screw in the throttle and raise the rpms a bit, drive and stop traffic for 15 20 mins and recheck condition.

        Comment

        Working...
        X