Readme

Collapse
No announcement yet.

rear defroster and sunroof motor

Collapse
X

rear defroster and sunroof motor

Collapse
 
  • Filter
  • Time
  • Show
Clear All
new posts

    rear defroster and sunroof motor

    Ok my rear defroster does not work. I replaced the ICU with a NEW one (because that is what some1 on here said to do) and still no fix. any sugestions???

    And the sunroof motor...again i checked on here and i changed the motor...NEW motor opened but it wouldnt close. Any sugestions???


    Thanks alot!,
    Connor

    #2
    ^^ please

    Comment


      #3
      =/ no one?

      Comment


        #4
        have you checked fuses and checked for current at the switches?

        Comment


          #5
          yup... ...i checked them all...they were all the same...so i dont no...any ideas
          Last edited by ronnoc; 16 Dec 2004, 19:38:40.

          Comment


            #6
            ^up up up^

            Comment


              #7
              defroster: did you re-wire your fogs?

              Comment


                #8
                nope...not inless the owner before me did...but umm it worked when I baught it

                Comment


                  #9
                  try checking to see if theres power to the little plugs on the side of there rear glass. the one that hooks up to the defroster. get a test light and see of theres power going there when the switch is turned on. if theres no power theres a breakfrom the switch to that wire or bad relay. if there is power then there might be a break on those defroster lines.

                  Comment


                    #10
                    Ever had window tint put on then taken off? If so thats your problem.

                    Comment


                      #11
                      thx! defroster fixed...now just the sunroof

                      Comment


                        #12
                        mine used to open but not close. it was the sunroof switch itself. all those years of opening and closing did its toll on the contacts. open up the switch itself to check. i replaced mine, and now works flawlessly.

                        Comment


                          #13
                          so what was the prob w/ your defroster?

                          Comment


                            #14
                            power goign to the little plug..had a friend (electrition) coem look at it for me...he did something...and now it works...so whet evere...now just the sunroof...ill check the switch..mine does open...but dosnt close...any1 have a switch for sale? or wanna give me one... =P

                            Comment


                              #15
                              How did you exchange th ICU unit and how much did the unit cost?

                              Comment


                                #16
                                sorry to bring up an old post i just saw ur question...i bought the ice for $20 (used all worked though) and as far as exchanging it..i just unplugged the battery and unpluged the old one (remembering which wire set went where) and plugged the new one in...in the service (repair) manual there was a diagram of where all the wires where...made it easyer...

                                Hope that helps agai sorry for bringing an old post up. i just noticed the question
                                sorry

                                Thanks,
                                Connor

                                p.s. idntglwiglisten the defroster has worked sience the ice was replaced...if i were a betting man ied say that fixed it.

                                Comment

                                Working...
                                X