Readme

Collapse
No announcement yet.

Rattling Noise behind my Tachometer Cluster

Collapse
X

Rattling Noise behind my Tachometer Cluster

Collapse
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Rattling Noise behind my Tachometer Cluster

    Problem is that when driving at any speed I can hear a rattling type noise right behind the speedometer/tachometer cluster. Someone tells me that it might be that the speedometer cable might need grease. Anyone with the same problems. If that is the problem can you please tell me how to remove the cluster to get to the speedometer cable?

    #2


    You should look around before asking, these have been covered in official TegTips as well as in the forum:

    Removing Gauge Cluster

    A little on Speedo Cables

    Detailed Speedo Cable Replacement Read the entire post before starting project.

    Comment


      #3
      Thanks for doint the search for me. I love it.

      Once again, I love it.

      Comment


        #4
        mine did that. it is the speedo cable if it is the same noise. the more i take out my gauge cluster the faster i am, but that 1st time took a while

        Comment


          #5
          Originally posted by apizzle
          Thanks for doing the work for me - Once again, I love it.


          Yeah, you're just lucky that there is me are others like me who believe that all like threads should cross-reference each other (even if the new thread only points to the answer thread). It makes it easier to find answers in the future for those of us who DO search.

          Comment

          Working...
          X