Readme

Collapse
No announcement yet.

Car starts and shuts off

Collapse
X

Car starts and shuts off

Collapse
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Car starts and shuts off

    I have 91 with a full xsi swap. I've been having a problem lately though. I'll go out to start it and it starts then shuts off. After that it won't start, I'll let it sit for a little while and it starts right up no problem. The only time it seems to do this is when it sits out in the sun all day. Anyone ever have a problem like this?

    #2
    Could be a Main Fuel Relay (MFR) problem. Search for that topic and you'll get all sorts of good info.

    Comment


      #3
      I was thinking it could be that but I do smell fuel when I crank it so I was thinking it was getting too much fuel and flooding it

      Comment


        #4
        Do you hear the fuel pump priming when you turn the ignition on?

        If you think you're getting fuel, then you need to check to see if you're getting spark.

        B&M makes a cheap fuel pressure gauge which installs on the top of your fuel filter. I can't even begin to tell you how handy it is to have this. You can automatically tell whether or not your fuel pump is going on and if you're building enough pressure...

        Comment


          #5
          I have one but my friend is using it so I'll have to get it back. I do smell fuel if I crank it over and the last time I pull a plug and checked it was getting spark. I thought it was flooding cause usually when I let it sit for a bit it starts right up. Today is the first time it hasn't

          Comment


            #6
            Originally posted by B18integra22 View Post
            I have one but my friend is using it so I'll have to get it back. I do smell fuel if I crank it over and the last time I pull a plug and checked it was getting spark. I thought it was flooding cause usually when I let it sit for a bit it starts right up. Today is the first time it hasn't
            where are u smelling the fuel coming from? thats important, if its coming from the engine bay u prolly have leaking injector o-rings.

            regarding the not starting when its hot, i'd definitely search mfr like colin mentioned. and yea, if u didn't notice, he asked if u could hear the fuel pump priming during the occurrences when it doesn't start. all this stuff can be found in the mfr teg tips issues n stuff. just know that bad distributors have similar symptoms to this as well. but if the fuel pump is priming then ur mfr is MOST LIKELY (not 100%) good.

            Comment


              #7
              Several things come to mind from your symptoms - main relays develop bad solder connections which are repairable, bad ignition switch, ignitor, or fuel pump - But check out this web site for touble shooting tips. It is the motherload of helpfull info http://techauto.tripod.com/

              Comment


                #8
                thanks for all your help, it definately has the symtoms of a bad main relay. I'll have to see if I can pick one up. thanks everyone

                Comment

                Working...
                X