Readme

Collapse
No announcement yet.

b16 vtec issues

Collapse
X

b16 vtec issues

Collapse
 
  • Filter
  • Time
  • Show
Clear All
new posts

    b16 vtec issues

    ok, i was talking to some of you guys on another guys thread. i now have all my stuff taken care of. i have a b16 with skunk2 intake man and blox stage1 cams/gears. i have no cel on now because i fixed the o2 problem. i hooked up both of them. runs much better but still having some issues when getting into vtec. i hit vtec and it struggles from about 4500 to 5500 then picks back up. any ideas of what could be causing this? once i get past 5500, no problems with power.

    #2
    What ecu are you running and is it chipped? OBD1 or 0?

    Comment


      #3
      virgin pr3 obd 0

      Comment


        #4
        Thats a good one, I am sort of leaning towards your cam timing but you might be having a fuel issue at switch over. What is the cam timing set at. I would look at that first. Put em back to staright up and see what you get. Also check your fuel pressure.

        Comment


          #5
          umm, i've changed my cam timing a lot now. ive been as far as plus 4 and back to minus 2. right now i have it set at plus 2. that is what blox says is best. advanced 1 or 2. i haven't checked my fuel pressure, but i can smell fuel through my air ducts when i hit vtec sometimes.

          Comment


            #6
            Have you had your injectors off recently? Did you change the o-rings, maybe you have fuel leaking by? When you change the cam timing does it get better, worse or the same? I think its a fuel issue then, I know its a pain in the ass but it might be worth your time to rig up a fuel gauge into the cabin so you can see the pressure as the car is being driven.

            Comment


              #7
              i just put the swap in 3 weeks ago so yes, i had he injectors off and did not change the rings. well if that is the problem, then the 550cc i have coming for my turbo set up should fix the problem then

              Comment


                #8
                fixed most of the problem, i found a leak in the fuel return hose right where it clamped to the pressure regulator. 90% better. it now just struggle a tad when hitting vtec untill about 5.5k and then it screams. i think a good tune will get it straightened out

                Comment

                Working...
                X