Readme

Collapse
No announcement yet.

b16a wiring problems

Collapse
X

b16a wiring problems

Collapse
 
  • Filter
  • Time
  • Show
Clear All
new posts

    b16a wiring problems

    hey ive just about completed my b16a conversion (out of a jdm xsi) but i have 2 connectors left over that i have no where to plug into.
    i have been told that now i have to take off the b16a engine harness and use my b18a one.. and wire up the 4 wires for vtec etc...
    im not really looking forward to this as it is one hell of a job to swap engine harnesses with the engine already in...
    this ever happen to anyone else and what did yous do to get around it ???
    heres pics the 2 plugs
    cheers

    [IMG][/IMG]
    [IMG][/IMG]

    #2
    you have round connectors, which means your car is obd0, therefore you didnt get the motor out of an xsi, its a first gen b16a. also you need to use your cars wiring harness and wire the extra vtec and knock wires in.hope that helps man.

    Comment


      #3
      so i have to take off the wiring harness of the b18 and use it on the b16.... im really not looking forward to swapping that over !! then engine is already in...
      and i did get the engine out of an xsi coz i saw the car with my own eyes ?? lol
      hmmm

      Comment


        #4
        Originally posted by mayberry4thgen
        you have round connectors, which means your car is obd0, therefore you didnt get the motor out of an xsi, its a first gen b16a.
        This does not make any sense.... Mr. Integra, I suggest you ignore this comment.

        You are going to want to use your b18a engine harness. The b16a engine harness is from a rhd car, which means the connections are on the wrong sides. It would have been wise to read the engine swap guide before starting your swap, however its still not too late, so you should go read that before you do any more work (hint, its in the Teg Tips).

        Comment


          #5
          im from australia so my car is right hand drive as well hehehehehe
          umm just finished changing it over
          it was fun

          ohh yeah and ive got every b16a swap guide i could find

          Comment


            #6
            im sorry, but i thought all obd0 connectors were the round ivory colors. and xsi tegs were obd1 which equals square gray connectors. new to the obd0 thing, i was always an accord/prelude guy.

            Comment


              #7
              Originally posted by mR_InTeGRa
              im from australia so my car is right hand drive as well hehehehehe
              umm just finished changing it over
              it was fun

              ohh yeah and ive got every b16a swap guide i could find
              man... i didn't even realize that... then yeah, you can use the jdm wiring harness..... (obviously wires need to be added if your car was not originally vtec equipped...but it sounds like you've got it all figured out )

              mayberry: they made xsi's in 89-91 as well, so there are both obd0 and obd1 xsi's.

              Comment


                #8
                Originally posted by Colin
                man... i didn't even realize that... then yeah, you can use the jdm wiring harness..... (obviously wires need to be added if your car was not originally vtec equipped...but it sounds like you've got it all figured out )

                mayberry: they made xsi's in 89-91 as well, so there are both obd0 and obd1 xsi's.

                hmm thanks for the info

                Comment


                  #9
                  yup all done and running
                  just have to wire up the 4 extra missing wires and im done woohoo
                  thanks for your help

                  Comment


                    #10
                    i just got my b16a1 as well and the wireharness ends where my old engine connectors end (b18a1 90integra gs)

                    two of the connectors are the same but i have that extra round one i belive..i just got the engine today didn't full unpack it

                    should it be like this? ..the connectors end on the passenger side

                    Comment

                    Working...
                    X