Readme

Collapse
No announcement yet.

Did b16 swap now problems..... help.

Collapse
X

Did b16 swap now problems..... help.

Collapse
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Did b16 swap now problems..... help.

    I have a 91 rs integ and just did a swap. i put a 1990 B16A with pr3 ecu. when my car is all nice and warmed up if i give gas to 2000 rpm and hold it my rpm slowly drops to idle then when i accelerate a lil more it will bog and raise a little.and when i drive its will do it and my car will jerk back in fourth like a surge like im learning to drive stick. what could this be???

    #2
    mine did that and i could not figure it out i checked the ecu and it was throwing code five map i look and pluged it in and it helped alot.. make sure all your vacuum is right and everything is pluged in

    Comment


      #3
      replace your 02 sensors. my b16 used to sputter when i drove also, kinda like if i was tapping the throttle every couple seconds when i was really holding the pedal steady

      Comment


        #4
        nope its none of that, any body else have suggestions???

        Comment


          #5
          Iacv?

          Comment


            #6
            Check TPS sensor and MAP sensor. Is it throwing any codes?

            Comment


              #7
              no codes. Its not map sensor i tryed my friends.

              Comment


                #8
                i have a question what car did ur b16 come out of ? its a jdm motor right ?

                Comment


                  #9
                  it is a 1990 B16A and i have pr3 ecu

                  Comment


                    #10
                    unplug your O2 sensors and drive it and see if it makes a difference. My b16 did the same thing yours is doing, so i pulled the O2's and that fixed it. Just get new O2 sensors once you can afford it (unlike me).

                    Comment


                      #11
                      if its none of that, you said you're just learning to drive stick, perhaps its you driving... not to sound like a jerk lol

                      Comment


                        #12
                        I was thinking the same thing today. I sat and tryed to brain storm, and i was thinking hey i have (2) o2 sensors whats the odds one is bad. i think thats what i will try, il pull emm out tommaror and throw new ones in. I will tell you guys how it went. Thanks sweet91integra

                        B20crxSC: i have been driving stick for two years i know how to drive lol.

                        Comment


                          #13
                          Originally posted by SDracerBOY
                          I have a 91 rs integ and just did a swap. i put a 1990 B16A with pr3 ecu. when my car is all nice and warmed up if i give gas to 2000 rpm and hold it my rpm slowly drops to idle then when i accelerate a lil more it will bog and raise a little.and when i drive its will do it and my car will jerk back in fourth like a surge like im learning to drive stick. what could this be???
                          hey bro you can have two problems. one problem could be that you are all wired for obd-0 and you need a pwo ecu. my frineds did the same thing when his ecu was defective. another thing is the distributor make sure you are using a non obd dist. even though if you werent it prolly wouldnt start but it is defintly a possibility. when i put my type r in i forget to swap dist. and when ever i would floor it it would die. just trying to help good luck

                          Comment


                            #14
                            its obd 0 ecu. But what dif would running pw0 and pr3 be, arent they pretty much same?

                            Comment


                              #15
                              For some reason i always thought the pwo was the only obdo vtec ecu. but i just know that if you have anything obd0 and you try anything obd1 or 2 you get major problems so i thought it would just try to help. did you check your dist they have a different amount of teeth
                              count and make sure

                              Comment


                                #16
                                Well i have been driving arond with both o2 senors un plugged and my car has not done it since. So im guessing one is acting up so it looks like i will replace both. What will it affect when i have them un plug?

                                TypeR+DA: my dist is obd-0.

                                Comment


                                  #17
                                  Originally posted by SDracerBOY
                                  Well i have been driving arond with both o2 senors un plugged and my car has not done it since. So im guessing one is acting up so it looks like i will replace both. What will it affect when i have them un plug?

                                  TypeR+DA: my dist is obd-0.
                                  i am not sure check honda tech. are you throwing a check engine light
                                  if you are your ecu might be in open loop which gives you better gas milage but hurts you on power. i have pwo ecu and when i throw check engine my vtec wont work either. not sure about yours though. but if you arent throwing a code then you should be all good. i know one time my buddy just took his o2 sensor out and ziptied it somewhere before and his car ran fan. But if you are worried about actually hurting the engine, dont be o2 sensors are not life or death of a motor

                                  Comment


                                    #18
                                    yeah it wont start with the wrong obd distributor, cause mine wouldnt, and my o2 sensors are still on crack but i have a obd 1 car and ecu so i put a four wire one in in a bung on my downpipe, blows an o2 code in only 3rd gear after 7 gs? Meh my cars possesed but I still love her.

                                    Comment

                                    Working...
                                    X