Readme

Collapse
No announcement yet.

Electrical is all messed up

Collapse
X

Electrical is all messed up

Collapse
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Electrical is all messed up

    This happen couple days ago my deck started to lose power for a half sec. then i comes back so i took the deck out and after that my electricity got all messed up, when I turn on my dome lights which won't turn on but then the light on the cluster is telling me that my door is open and my clock turns off when i turn the dome light off the light goes away and the clock resets.
    any help would be most thankfull.
    btw check all the fuses and couldn't find anything
    thanks

    #2
    Originally posted by blueteg
    This happen couple days ago my deck started to lose power for a half sec. then i comes back so i took the deck out and after that my electricity got all messed up, when I turn on my dome lights which won't turn on but then the light on the cluster is telling me that my door is open and my clock turns off when i turn the dome light off the light goes away and the clock resets.
    any help would be most thankfull.
    btw check all the fuses and couldn't find anything
    thanks
    You have grounding problems , check all dash grounds, most will be found at the kickpanels on the "A" pillars 94

    Comment


      #3
      check the clock/interior light/cigirette lighter fuse......i had the same prob when i installed my deck a couple days ago but a new fuse fixed it up

      BTW.....check the fuse again..because the first rtime i looked at it it looked fine...but i looked at it again closely and it was broke

      Comment


        #4
        Originally posted by 2GTegLs
        check the clock/interior light/cigirette lighter fuse......i had the same prob when i installed my deck a couple days ago but a new fuse fixed it up

        BTW.....check the fuse again..because the first rtime i looked at it it looked fine...but i looked at it again closely and it was broke
        thanks man i did check the fuses again and you were right the light/cigirette fuse was blowen, changed that fuse and it works fine so far.
        thanks again

        Comment

        Working...
        X